Log in

View Full Version : Having problems with IE8


Schugar
12-01-2010, 09:46 AM
Hi!

I don't know if someone mentioned it before but I'm having huge problems with IE8 and shadowsongeurope.com (did not try it in other versions of IE).

Getting errors like:
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; MS-RTC LM 8)
Timestamp: Tue, 12 Jan 2010 09:41:08 UTC


Message: HTML Parsing Error: Unable to modify the parent container element before the child element is closed (KB927917)
Line: 0
Char: 0
Code: 0
URI: http://shadowsongeurope.com/forum/newthread.php?do=newthread&f=65

etc.

Often I can't load the forums at all, and if I can I get this tiny tiny spot in the browser with a scroll to the right, which I can't really use to read anything.

(I know that the most viable solution is to not use IE at all, but I thought I should mention the problems so if you want, you can fix them, I can post screen shots in pm if you like).

Besides the issues I really like the new shadowsongeurope.com :)

Notafama
12-01-2010, 05:24 PM
Use a different browser.

Schugar
12-01-2010, 09:31 PM
yeah right....

Use a different browser.

(I know that the most viable solution is to not use IE at all, but I thought I should mention the problems so if you want, you can fix them, I can post screen shots in pm if you like).

My post was basically a hint to the developers about a problem that they might want to fix. In the perfect world everybody could choose their own web browser, unfortunately not everyone is living in that world though, at least not at work.

(waiting for the next comment - Switch job? ;))

dantheman
12-01-2010, 09:54 PM
Switch job.

Goonerr
12-01-2010, 10:04 PM
Well considering IE is still the most widely used browser (even if it is shit) it would probably be wise to fix it, your more likely to attract more visitors if they can acctually browse the site without errors.

Personally i've never had any problems using IE (unlike some people getting hacked all the time and blaming it on IE, a load of tosh if you ask me)

Llort
13-01-2010, 12:30 AM
The problem lies in altering the HTML code before the HTML code is fully loaded.

E.g. you can't modify the body tag (adding/removing sub-nodes) if the HTML isn't fully loaded yet.

This only occurs in ANY IE version, not only IE8. And it is very annoying, to say the least.

Gwynin
13-01-2010, 12:14 PM
Ive visited SSE for about 4 years only using IE6/7/8 and never had any errors like that, so I doubt its a error that comes often and for alot of users.

Schugar
13-01-2010, 12:45 PM
Ive visited SSE for about 4 years only using IE6/7/8 and never had any errors like that, so I doubt its a error that comes often and for alot of users.

This makes it even more strange. I run IE8 with both Windows Vista and Windows 7. (Never had any problems with the old sites however)
Here are some pictures:

http://i882.photobucket.com/albums/ac28/Schugar/browseMore.png
http://i882.photobucket.com/albums/ac28/Schugar/browseAll.png
http://i882.photobucket.com/albums/ac28/Schugar/browse.png

Could there be some setting I manage to do on both machines?

Ruoste
13-01-2010, 01:14 PM
If you want to go to forums with IE you can use link http://www.shadowsongeurope.com/forum/ which bypasses the rest of the site. This way you also get to use all of your screen for the forums. I do this with Opera because the forums frame is very small in that.

Schugar
13-01-2010, 01:32 PM
Ruoste, that works like a charm in my IE8 on my vista machine (at work). Thanks :)

dantheman
13-01-2010, 01:56 PM
To be fair, thats what I do at my work place too. It doesn't like linking to the forums from the main page.

Gwynin
13-01-2010, 03:42 PM
Must admit that I never access the forums via the frontpage, which might be why I never had any issues. :)

Turiel
22-01-2010, 08:33 AM
I've had a few people with IE8 issues. Maybe try legacy mode in IE8?

Kryptonix
24-01-2010, 11:36 AM
ie8

haha IE!