Log in

View Full Version : Workaround for latency issues caused by sound


Gwynin
13-02-2008, 12:42 PM
Yes yes title sounds a bit weird, but atleast myself actually have had this issue since 2.2 (new FMOD sound system version added to WoW). :)
It made my wow unplayable due to wow either being very laggy or vent/ts in the background running with 2000+ latency, this even happend with all sounds disabled in wow.

And here is the technical stuff

For Soundblaster users (This works for me, have a X-FI card).


1. You have to go into your registry ( in win xp you click Start, click Run, type regedit)


2. You go to :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\CreativeTech\Emu10kx\DriverSettings\Wave\Pin#000 00002

or in :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\CreativeTech\20X\DriverSettings\Wave\Pin#0000000 2


3. Set Turbo to 0 instead of 1.

Work for now. I'm using a X-fi but I thnk it might work for audigy too. My FPS are not as good as they where but at least I can set back acceleration to complete instead of basic in dxdiag and get a "better" sound.


I have found this fix to solve sound stutters in Black and White 2 :
http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&message.id=38693&query.id=17



And something that 'might' work for Realtek HD Audio onboard chips


1) open your windows registry (Start -> Run -> regedit)
2) click on the "My Computer" icon (to make sure the search runs through the entire registry)
3) find the name "TurboPlay" (using Ctrl+F or the Edit menu)
4) there should be a few folders, with a REG_SZ value in it called "(Default)"
5) double-click it and set it to 0
6) restart your computer


The original post I made can be found here.
http://forums.worldofwarcraft.com/thread.html?topicId=2035718402&sid=1

If the word "TurboPlay" doesn't work, try "turbo" and use your common sense to change the obvious values from 1 to 0.

MAKE SURE YOU BACKUP YOUR REGISTRY BEFORE ATTEMPTING TO CHANGE ANYTHING.
USE THIS ADVICE AT YOUR OWN RISK.

Gwynin
13-02-2008, 12:48 PM
Some other fixes that might help with different kinds of sound related issues.


Using this command help me to get less skip sounds :

/console SoundMemoryCache 8 (type this in chat then restart wow)


And a different fix for sound skipping


http://forums.worldofwarcraft.com/thread.html?topicId=2040218912&sid=1
I was having normal latency in game while questing etc., but when I went to Gruul's after we pulled my latency spiked to 1500ms and higher. Same thing when I tried Pvping, and nothing fixed it. Checked the router, WoW caches, got rid of all addons, etc. In between pulls, my latency would go back to normal, I just couldn't raid or pvp without massive lag spikes. I couldn't find any blue answers here on the forums so my bf and I looked around and this is what we found.

Found this fix (which worked for me) on the European forums.

http://forums.wow-europe.com/thread.html?topicId=1015913737&sid=1

He lists the different fixes for the different latency issues like the sound one, but for those experiencing HIGH LATENCY WHILE RAIDING/PVPING, but not outside of those, this should work.

Copied from link:

---------------------------------------------
Changing the Config.wtf file:
---------------------------------------------

This solution will have you poking inside the configuration-file of wow. Maybe not a great idea, but hey, I am willing to try.

Locate the config.wtf file in the WTF directory, inside your WoW-folder. Open it in notepad or wordpad, and do the following:

1. Look through the file, and see if you can find "gxFixLag"
2. If you find it, change the number from 0 to 1
3. If you can't find it, try to add a line like this one:

SET gxFixLag "1"